Posts by xii5ku

1) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6717)
Posted 11 Apr 2020 by xii5ku
Post:
@robertmiles, I can't respond to your Ralph@home/ Rosetta@home related points, because I am new to Ralph and lack the insight. But a quick response to this unrelated item:
robertmiles wrote:

I looked at TN-Grid. They are currently not accepting new users.
This is not correct. New users can join any time. They only need to create the account via the web site and need to enter the invitation code from the main page. AFAIK this is a measure to reduce spam, not to hinder new contributors to join. That said, it is true that their work generator always had and still has a limited pace. But my experience during the last few days was that my hosts remained saturated.


robertmiles wrote:
They are thinking of starting some COVID-19 work, which would probably start a flood of new users if they don't keep limiting them.
They already started such work. They just don't communicate this widely to boinc contributors because of the limited pace of the work generator.

/end-offtopic
2) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6714)
Posted 10 Apr 2020 by xii5ku
Post:
Linux i686 application version problem in v4.12 + v4.15
(100% reproducible on my Linux EMT64 hosts, problem not reproducible with Linux x86-64 application version)

On April 7 at Rosetta@home, I reported that all "Rosetta v4.12 i686-pc-linux-gnu" tasks got stuck at 1 decoy and finished after target CPU time + 4 h watchdog overtime, whereas all "Rosetta v4.12 x86_64-pc-linux-gnu" ran normally on the same hosts. (Rosetta forum thread "Rosetta v4.12 i686-pc-linux-gnu" : fixed 20 h CPU time, fixed 20 credits)

Last night I received a bunch of tasks from Ralph to 4 of the same set of computers.
I had the default target CPU time configured at Ralph, which is 1 hour.

I have 257 valid results, of 257 tasks received:

  • All 169 "Rosetta v4.15 x86_64-pc-linux-gnu tasks finished after 1 hour and generated at the order of 20...40 decoys, according to spot checks.
  • All 88 "Rosetta v4.15 i686-pc-linux-gnu tasks tasks finished after 5 = 1+4 hours and generated (3x) 9, 8, (3x) 7, 6, (3x) 5, (8x) 4, (5x) 3, (9x) 2, (55x) 1 decoys.

So there is slight progress from v4.12 to v4.15 on my hosts, but not a breakthrough yet.

i686 tasks with more than 1 decoy, and a minority of 1-decoy tasks, received varying but of course low credit.

The majority of i686 1-decoy tasks received the usual fixed 20.00 credits. These ones had the "WARNING! cannot get file size for default.out.gz: could not open file." line in their stderr, while the other tasks with more or less than 20.00 credits did not.

host 44866: received 54 i686 tasks
host 44867: received 53 x86_64 tasks, same hardware and OS as 44866
host 44869: received 34 i686 tasks, almost same hardware, same OS
host 44870: received 116 x86_64 tasks, different hardware, similar OS

hosts 44866...44869: dual Broadwell-EP, openSUSE 15.0
. . . . These hosts received both i686 and x86_64 jobs at Rosetta and at Ralph, with the described consistent results.

host 44870: dual Rome, openSUSE 15.1
. . . . This host received only x86_64 jobs at Rosetta and Ralph so far, hence only had good x86_64 results yet (no i686 jobs received).

I furthermore have a single-socket Haswell with Gentoo Linux, which received only x86_64 jobs at Rosetta but no jobs at Ralph yet.

My prior report on Rosetta v4.12 was while I ran Rosetta@home exclusively on the hosts. This report on v4.15 was while I ran TN-Grid with 0 % resource share + Ralph with 100 % resource share. But at least three of the four computers ended up with almost all threads running Ralph jobs that way, whereas the third computer worked at a mixed workload of ~1/3rd Ralph + ~2/3rds TN-Grid.







©2020 University of Washington
http://www.bakerlab.org