RALPH@home

Bug reports for Ralph 5.14

  UW Seal
 
[ Home ] [ Join ] [ About ] [ Participants ] [ Community ] [ Statistics ]
  [ login/out ]


Advanced search

Message boards : RALPH@home bug list : Bug reports for Ralph 5.14

AuthorMessage
Rhiju
Forum moderator
Project developer
Project scientist

Joined: Feb 14 06
Posts: 161
ID: 4
Credit: 3,725
RAC: 0
Message 1596 - Posted 12 May 2006 19:02:45 UTC

    Please post bugs in 5.14. A few comments:

    (1) The \"phantom chain\" or \"broken chain\" that appear in some workunits are OK -- they\'re new science modes we\'re testing that either focus on specific parts of the protein or rearrange the protein topology to better sample long-range contacts.

    (2) The debugger messages (which caused slowdowns for some users with 5.10-5.12, and were removed in 5.13)
    have been put back into ralph. But they\'re not on by default. We\'ll ask Rom to post here and fill you in on how to turn them on.

    (3) We\'re testing a new science mode which uses the sequence and structural information from homologous proteins in an early phase of the simulation, but then returns to the target protein sequence in the final refinement phase.

    (4) We\'re also continuing our efforts to reduce memory usage by rosetta/ralph!



    ____________

    dainenyu

    Joined: Feb 19 06
    Posts: 6
    ID: 565
    Credit: 7,772
    RAC: 0
    Message 1598 - Posted 12 May 2006 21:28:46 UTC - in response to Message 1596.

      Last modified: 12 May 2006 21:30:06 UTC

      Downloaded 6 WUs, all failed immediately, giving message

      5/12/2006 5:41:23 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom023_1fna__509_8_0 (Incorrect function. (0x1) - exit code 1 (0x1))
      5/12/2006 5:41:29 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom028_1fna__509_6_0 (Incorrect function. (0x1) - exit code 1 (0x1))
      5/12/2006 5:41:38 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom009_1fna__509_5_0 (Incorrect function. (0x1) - exit code 1 (0x1))
      5/12/2006 5:41:38 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom009_1fna__509_7_0 (Incorrect function. (0x1) - exit code 1 (0x1))
      5/12/2006 5:41:40 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom009_1fna__509_10_0 (Incorrect function. (0x1) - exit code 1 (0x1))
      5/12/2006 5:41:44 PM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom029_1fna__509_7_0 (Incorrect function. (0x1) - exit code 1 (0x1))

      WU numbers are 97527, 97483, 97460, 97440, 97430, 97382.

      Edit: stderr out reads
      <core_client_version>5.4.9</core_client_version>
      <message>
      Incorrect function. (0x1) - exit code 1 (0x1)
      </message>
      <stderr_txt>
      ERROR:: Exit at: .\\map_sequence.cc line:495

      </stderr_txt>

      ____________

      TCU Computer Science

      Joined: Feb 16 06
      Posts: 5
      ID: 330
      Credit: 241,166
      RAC: 0
      Message 1599 - Posted 12 May 2006 21:45:54 UTC

        I upgraded to the latest stable release of the BOINC client (5.4.9 for Mac OS X) and now I\'m getting immediate failures:

        Fri May 12 16:47:16 2006|ralph@home|Starting task MAPRELAX_TEST_hom018_1fna__509_7_0 using rosetta_beta version 514
        Fri May 12 16:47:18 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom018_1fna__509_7_0 (process exited with code 1 (0x1))

        Fri May 12 16:48:28 2006|ralph@home|Starting task MAPRELAX_TEST_hom001_1fna__509_11_0 using rosetta_beta version 514
        Fri May 12 16:48:30 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom001_1fna__509_11_0 (process exited with code 1 (0x1))

        Fri May 12 16:53:20 2006|ralph@home|Starting task MAPRELAX_TEST_hom003_1fna__509_13_0 using rosetta_beta version 514
        Fri May 12 16:53:22 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom003_1fna__509_13_0 (process exited with code 1 (0x1))

        Fri May 12 16:57:32 2006|ralph@home|Starting task MAPRELAX_TEST_hom022_1fna__509_10_0 using rosetta_beta version 514
        Fri May 12 16:57:34 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom022_1fna__509_10_0 (process exited with code 1 (0x1))

        Fri May 12 17:01:47 2006|ralph@home|Starting task MAPRELAX_TEST_hom013_1fna__509_11_0 using rosetta_beta version 514
        Fri May 12 17:01:50 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom013_1fna__509_11_0 (process exited with code 1 (0x1))

        Fri May 12 17:05:50 2006|ralph@home|Starting task MAPRELAX_TEST_hom028_1fna__509_12_0 using rosetta_beta version 514
        Fri May 12 17:05:53 2006|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom028_1fna__509_12_0 (process exited with code 1 (0x1))

        Profile Fuzzy Hollynoodles
        Avatar

        Joined: Feb 19 06
        Posts: 37
        ID: 585
        Credit: 2,089
        RAC: 0
        Message 1600 - Posted 12 May 2006 22:45:00 UTC

          Last modified: 12 May 2006 22:50:03 UTC

          I wanted my Seti Beta 5.14 WU finished, so I suspended the 5.14 Ralph WU, which apparently killed it (or what?)

          http://ralph.bakerlab.org/workunit.php?wuid=97405

          Result: http://ralph.bakerlab.org/result.php?resultid=111703

          From my log:

          5/13/2006 12:57:29 AM|SETI@home|Restarting task 01mr99aa.26277.31696.309670.3.101_1 using setiathome_enhanced version 512
          5/13/2006 12:57:29 AM|SETI@home Beta Test|Pausing task 05au01ab.24507.112.847158.3.93_6 (removed from memory)
          5/13/2006 12:58:58 AM||Rescheduling CPU: result suspended, resumed or aborted by user
          5/13/2006 12:58:58 AM|SETI@home|Pausing task 01mr99aa.26277.31696.309670.3.101_1 (removed from memory)
          5/13/2006 12:58:58 AM|ralph@home|Starting task MAPRELAX_TEST_hom003_1fna__509_6_0 using rosetta_beta version 514
          5/13/2006 12:59:01 AM||Rescheduling CPU: result suspended, resumed or aborted by user
          5/13/2006 12:59:02 AM|rosetta@home|Restarting task TEST_HOMOLOG_ABRELAX_hom003_1fna__503_12404_0 using rosetta version 513
          5/13/2006 12:59:02 AM|ralph@home|Pausing task MAPRELAX_TEST_hom003_1fna__509_6_0 (removed from memory)
          5/13/2006 12:59:03 AM|ralph@home|Unrecoverable error for result MAPRELAX_TEST_hom003_1fna__509_6_0 (Forkert funktion. (0x1) - exit code 1 (0x1))
          5/13/2006 12:59:03 AM|ralph@home|Deferring scheduler requests for 1 minutes and 0 seconds
          5/13/2006 12:59:03 AM||Rescheduling CPU: application exited
          5/13/2006 12:59:03 AM|ralph@home|Computation for task MAPRELAX_TEST_hom003_1fna__509_6_0 finished

          5/13/2006 12:59:06 AM||Rescheduling CPU: result suspended, resumed or aborted by user
          5/13/2006 12:59:06 AM|LHC@home|Restarting task wfeb1A_v6s4vvnom_mqx__19__64.258_59.268__4_6__6__75_1_sixvf_boinc202329_1 using sixtrack version 467
          5/13/2006 12:59:06 AM|rosetta@home|Pausing task TEST_HOMOLOG_ABRELAX_hom003_1fna__503_12404_0 (removed from memory)
          5/13/2006 12:59:09 AM||Rescheduling CPU: result suspended, resumed or aborted by user
          5/13/2006 12:59:10 AM|LHC@home|Pausing task wfeb1A_v6s4vvnom_mqx__19__64.258_59.268__4_6__6__75_1_sixvf_boinc202329_1 (removed from memory)
          5/13/2006 12:59:10 AM|LHC@home|Starting task wfeb1A_v6s4vvnom_mqx__3__64.265_59.275__10_12__6__55_1_sixvf_boinc181092_5 using sixtrack version 467
          5/13/2006 12:59:14 AM||Rescheduling CPU: result suspended, resumed or aborted by user
          5/13/2006 12:59:15 AM|SETI@home Beta Test|Restarting task 05au01ab.24507.112.847158.3.93_6 using setiathome_enhanced version 514
          5/13/2006 12:59:15 AM|LHC@home|Pausing task wfeb1A_v6s4vvnom_mqx__3__64.265_59.275__10_12__6__55_1_sixvf_boinc181092_5 (removed from memory)
          5/13/2006 12:59:15 AM|SETI@home Beta Test|Sending scheduler request to http://setiboinc.ssl.berkeley.edu/beta_cgi/cgi
          5/13/2006 12:59:15 AM|SETI@home Beta Test|Reason: To fetch work
          5/13/2006 12:59:15 AM|SETI@home Beta Test|Requesting 3994 seconds of new work
          5/13/2006 12:59:20 AM|SETI@home Beta Test|Scheduler request succeeded
          5/13/2006 12:59:22 AM|SETI@home Beta Test|Started download of file 01jn01aa.7728.12640.709662.3.121
          5/13/2006 12:59:35 AM|SETI@home Beta Test|Finished download of file 01jn01aa.7728.12640.709662.3.121
          5/13/2006 12:59:35 AM|SETI@home Beta Test|Throughput 29497 bytes/sec
          5/13/2006 12:59:36 AM||Rescheduling CPU: files downloaded
          5/13/2006 12:59:56 AM|ralph@home|Sending scheduler request to http://ralph.bakerlab.org/ralph_cgi/cgi
          5/13/2006 12:59:56 AM|ralph@home|Reason: Requested by user
          5/13/2006 12:59:56 AM|ralph@home|Reporting 1 tasks
          5/13/2006 1:00:01 AM|ralph@home|Scheduler request succeeded






          ____________

          "I'm trying to maintain a shred of dignity in this world." - Me

          wizzszz

          Joined: Apr 28 06
          Posts: 17
          ID: 1333
          Credit: 1,128
          RAC: 0
          Message 1601 - Posted 12 May 2006 22:59:10 UTC

            Last modified: 12 May 2006 23:00:28 UTC

            Had the same error using BOINC V5.4.9, WU aborted immediately, reporting this error:

            Unrecoverable error for result MAPRELAX_TEST_hom007_1fna__510_3_0 (Unzulässige Funktion. (0x1) - exit code 1 (0x1))

            ____________

            Moderator9
            Forum moderator

            Joined: Feb 16 06
            Posts: 251
            ID: 210
            Credit: 0
            RAC: 0
            Message 1605 - Posted 13 May 2006 1:50:16 UTC - in response to Message 1601.

              Last modified: 13 May 2006 2:13:35 UTC

              Had the same error using BOINC V5.4.9, WU aborted immediately, reporting this error:

              Unrecoverable error for result MAPRELAX_TEST_hom007_1fna__510_3_0 (Unzul�ssige Funktion. (0x1) - exit code 1 (0x1))

              ALL of these groups of errors look like a bad batch of Work Units. I have over 20 on each of my machines as well. I will bring this to Rhiju\'s attantion.

              EDIT: Rhiju is \"commuting\" at the moment but I am advised that as I expected this is a bad batch of Work Units. Rhiju says to let you know-
              \"A new batch has been queued up. These should pass through very quickly. Sorry for the inconvience.\"

              ____________
              Moderator9
              RALPH@home FAQs
              RALPH@home Guidelines
              Moderator Contact

              dainenyu

              Joined: Feb 19 06
              Posts: 6
              ID: 565
              Credit: 7,772
              RAC: 0
              Message 1606 - Posted 13 May 2006 3:26:49 UTC - in response to Message 1605.

                EDIT: Rhiju is \"commuting\" at the moment but I am advised that as I expected this is a bad batch of Work Units. Rhiju says to let you know-
                \"A new batch has been queued up. These should pass through very quickly. Sorry for the inconvience.\"[/b]


                I\'ve got a couple of the new WUs (HOMOLOG_ABRELAX_hom*) and they seem to be running fine, almost an hour in.
                ____________

                wizzszz

                Joined: Apr 28 06
                Posts: 17
                ID: 1333
                Credit: 1,128
                RAC: 0
                Message 1607 - Posted 13 May 2006 4:00:07 UTC

                  Last modified: 13 May 2006 4:10:24 UTC

                  Fetched a new WU, this time it started w/o error.
                  RMSD is missing, I assume that it should be like that, because the native graphic is missing, too...

                  This causes the RMSD/Lowest Energy graphic to vanish, only a single red spot at the left edge is displayed.
                  And the description text is a bit too long.
                  (display end at \"has very close seque\")

                  So nothing serious, everything else works fine, even the graphics!

                  Accepted Energy is now below -216 for the second model.
                  Seems like the stranding algorithm improvements work fine.

                  Virtual memory load is about 132 MB, no clue what it was before...

                  ____________

                  Moderator9
                  Forum moderator

                  Joined: Feb 16 06
                  Posts: 251
                  ID: 210
                  Credit: 0
                  RAC: 0
                  Message 1608 - Posted 13 May 2006 4:33:26 UTC - in response to Message 1607.

                    Last modified: 13 May 2006 5:04:05 UTC

                    Fetched a new WU, this time it started w/o error.
                    RMSD is missing, I assume that it should be like that, because the native graphic is missing, too...

                    This causes the RMSD/Lowest Energy graphic to vanish, only a single red spot at the left edge is displayed.
                    And the description text is a bit too long.
                    (display end at \"has very close seque\")

                    So nothing serious, everything else works fine, even the graphics!

                    Accepted Energy is now below -216 for the second model.
                    Seems like the stranding algorithm improvements work fine.

                    Virtual memory load is about 132 MB, no clue what it was before...


                    All of the CASP7 target Work Units will have this display type. All that you describe is normal (except the long text overrun). Since they do not know the structure, they do not have the RMSD value, the Natural structure, or any other comparative information so it cannot be displayed. Because the RMSD is unknown, this forces the value to zero and the red dots all display at what would be the zero point of the RMSD graph (to the left of the box). As close as they can get to the graphic we all are familiar with is to show the accepted and lowest energy shapes as they occur. Rhiju has said they will work on the text overrun.

                    ____________
                    Moderator9
                    RALPH@home FAQs
                    RALPH@home Guidelines
                    Moderator Contact

                    [B^S] suguruhirahara

                    Joined: Mar 5 06
                    Posts: 40
                    ID: 992
                    Credit: 6,001
                    RAC: 0
                    Message 1609 - Posted 13 May 2006 9:11:40 UTC

                      Last modified: 13 May 2006 9:45:03 UTC

                      OS : WindowsXP Professional x64 Edition
                      CPU : Intel PentiumD 920 (2.80GHz)
                      Used RAM : approx. 115MB x2 at max. / 1GB
                      Graphic card: nVidia GeForce6600GT 128MB
                      BOINC version : the newest, 5.4.9

                      Work tasks - OK before closed
                      Graphic - OK

                      They worked fine without error at first. However, once BOINC client has been closed and restarted, the taskes which were being done more than half started from the beginning. Is it an error, or due to my preference of RALPH?

                      ____________

                      rbpeake

                      Joined: Feb 16 06
                      Posts: 19
                      ID: 218
                      Credit: 3,370
                      RAC: 0
                      Message 1610 - Posted 13 May 2006 11:38:13 UTC

                        Last modified: 13 May 2006 11:39:40 UTC

                        In case anyone missed this on the Rosetta board, here is an interesting thought on why the debugger code might have been causing the many page faults.

                        Rosetta Post
                        ____________

                        wizzszz

                        Joined: Apr 28 06
                        Posts: 17
                        ID: 1333
                        Credit: 1,128
                        RAC: 0
                        Message 1611 - Posted 13 May 2006 12:40:35 UTC - in response to Message 1610.

                          Last modified: 13 May 2006 12:51:39 UTC

                          In case anyone missed this on the Rosetta board, here is an interesting thought on why the debugger code might have been causing the many page faults.

                          Rosetta Post



                          So I think it would be useful, if all the guys with the \'hanging/slow\' machines post here what cpu type they got (HT/dual core/single core)!

                          If the error occures only there, it would help the developers a lot!
                          ____________

                          Moderator9
                          Forum moderator

                          Joined: Feb 16 06
                          Posts: 251
                          ID: 210
                          Credit: 0
                          RAC: 0
                          Message 1613 - Posted 13 May 2006 15:01:19 UTC - in response to Message 1609.

                            OS : WindowsXP Professional x64 Edition
                            CPU : Intel PentiumD 920 (2.80GHz)
                            Used RAM : approx. 115MB x2 at max. / 1GB
                            Graphic card: nVidia GeForce6600GT 128MB
                            BOINC version : the newest, 5.4.9

                            Work tasks - OK before closed
                            Graphic - OK

                            They worked fine without error at first. However, once BOINC client has been closed and restarted, the taskes which were being done more than half started from the beginning. Is it an error, or due to my preference of RALPH?

                            [color=darkred]If the work units start, and then you stop BOINC before about 25-40 min of processing, or in any case before the percent complete is more than 1.4%, when you restart BOINC they will start from zero. [color]
                            ____________
                            Moderator9
                            RALPH@home FAQs
                            RALPH@home Guidelines
                            Moderator Contact

                            [B^S] suguruhirahara

                            Joined: Mar 5 06
                            Posts: 40
                            ID: 992
                            Credit: 6,001
                            RAC: 0
                            Message 1614 - Posted 13 May 2006 15:18:04 UTC - in response to Message 1613.

                              Last modified: 13 May 2006 15:18:29 UTC

                              ...They worked fine without error at first. However, once BOINC client has been closed and restarted, the taskes which were being done more than half started from the beginning. Is it an error, or due to my preference of RALPH?

                              If the work units start, and then you stop BOINC before about 25-40 min of processing, or in any case before the percent complete is more than 1.4%, when you restart BOINC they will start from zero.


                              Is it an unavoidable thing or an error with just this version?

                              ____________

                              Rhiju
                              Forum moderator
                              Project developer
                              Project scientist

                              Joined: Feb 14 06
                              Posts: 161
                              ID: 4
                              Credit: 3,725
                              RAC: 0
                              Message 1615 - Posted 13 May 2006 20:50:11 UTC - in response to Message 1605.

                                Hi: I wanted to quickly apologize for the batch of bad WU\'s yesterday on ralph. Thanks for your patience! Its actually a new scientific mode in Rosetta, and I think I know why the WUs were failing on ralph. Will be testing the fix later today.

                                Had the same error using BOINC V5.4.9, WU aborted immediately, reporting this error:

                                Unrecoverable error for result MAPRELAX_TEST_hom007_1fna__510_3_0 (Unzul�ssige Funktion. (0x1) - exit code 1 (0x1))

                                ALL of these groups of errors look like a bad batch of Work Units. I have over 20 on each of my machines as well. I will bring this to Rhiju\'s attantion.

                                EDIT: Rhiju is \"commuting\" at the moment but I am advised that as I expected this is a bad batch of Work Units. Rhiju says to let you know-
                                \"A new batch has been queued up. These should pass through very quickly. Sorry for the inconvience.\"


                                ____________

                                Message boards : RALPH@home bug list : Bug reports for Ralph 5.14


                                Home | Join | About | Participants | Community | Statistics

                                Copyright © 2017 University of Washington

                                Last Modified: 20 Nov 2008 19:41:56 UTC
                                Back to top ^