Testing a switch to using SSL (Secure Socket Layer)

Message boards : News : Testing a switch to using SSL (Secure Socket Layer)

To post messages, you must log in.

AuthorMessage
Admin
Project administrator

Send message
Joined: 15 Dec 17
Posts: 252
Credit: 0
RAC: 0
Message 6723 - Posted: 23 Apr 2020, 18:04:28 UTC

We are testing a switch to using https:// (SSL). Please post any issues in the discussion of this news post.
ID: 6723 · Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 9 Apr 08
Posts: 676
Credit: 1,314,864
RAC: 2,955
Message 6724 - Posted: 23 Apr 2020, 20:02:56 UTC - in response to Message 6723.  

We are testing a switch to using https:// (SSL). Please post any issues in the discussion of this news post.

This is the message:
23/04/2020 22:01:02 | ralph@home | This project is using an old URL. When convenient, remove the project, then add https://ralph.bakerlab.org/
ID: 6724 · Report as offensive    Reply Quote
CIA

Send message
Joined: 5 Apr 20
Posts: 13
Credit: 84,696
RAC: 253
Message 6725 - Posted: 23 Apr 2020, 20:16:10 UTC - in response to Message 6723.  

We are testing a switch to using https:// (SSL). Please post any issues in the discussion of this news post.


I switched a few machines over, but am not getting work on them. At the same time I'm getting loads of work on my older non-SSL Ralph boxes.
ID: 6725 · Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 9 Apr 08
Posts: 676
Credit: 1,314,864
RAC: 2,955
Message 6726 - Posted: 23 Apr 2020, 20:22:26 UTC - in response to Message 6725.  

At the same time I'm getting loads of work on my older non-SSL Ralph boxes.

Same here.
ID: 6726 · Report as offensive    Reply Quote
Xavier Wallece

Send message
Joined: 29 Mar 20
Posts: 2
Credit: 3,129
RAC: 0
Message 6727 - Posted: 23 Apr 2020, 20:39:02 UTC
Last modified: 23 Apr 2020, 20:42:06 UTC

After re-adding the project using https://ralph.bakerlab.org/
The following workunits failed after uploading (and i am the second person to get the error)
https://ralph.bakerlab.org/workunit.php?wuid=4473391
https://ralph.bakerlab.org/workunit.php?wuid=4475616
https://ralph.bakerlab.org/workunit.php?wuid=4475916
https://ralph.bakerlab.org/workunit.php?wuid=4473091


</stderr_txt>
<message>
upload failure: <file_xfer_error>
<file_name>Mini_Protein_binds_IL6R_COVID-19_test3_SAVE_ALL_OUT_IGNORE_THE_REST_5aj5gu8j_32_31_0_r491574971_0</file_name>
<error_code>-161 (not found)</error_code>
</file_xfer_error>

OR it fails with
<error_code>-240 (stat() failed)</error_code>
ID: 6727 · Report as offensive    Reply Quote
Trotador

Send message
Joined: 7 May 10
Posts: 33
Credit: 14,403,306
RAC: 333
Message 6728 - Posted: 23 Apr 2020, 21:16:54 UTC
Last modified: 23 Apr 2020, 21:18:46 UTC

Working OK for me. Changed several hosts and all of them have received units, also the ones not changed,

Edit: also having the errors described in previous post. It does not seem to me to be related to SSL, but who knows.
ID: 6728 · Report as offensive    Reply Quote
Profile dekim
Volunteer moderator
Project administrator
Project developer
Project scientist

Send message
Joined: 20 Jan 06
Posts: 250
Credit: 542,654
RAC: 0
Message 6729 - Posted: 23 Apr 2020, 21:20:21 UTC - in response to Message 6727.  

Please let me know if these issues persist.
ID: 6729 · Report as offensive    Reply Quote
Xavier Wallece

Send message
Joined: 29 Mar 20
Posts: 2
Credit: 3,129
RAC: 0
Message 6730 - Posted: 23 Apr 2020, 21:38:29 UTC - in response to Message 6727.  

After re-adding the project using https://ralph.bakerlab.org/
The following workunits failed after uploading (and i am the second person to get the error)


These tasks where very short (30 seconds to produce a result). Other tasks that run for 1 hour have no problems.
ID: 6730 · Report as offensive    Reply Quote
Trotador

Send message
Joined: 7 May 10
Posts: 33
Credit: 14,403,306
RAC: 333
Message 6731 - Posted: 23 Apr 2020, 22:11:49 UTC

I've checked and It also occurs in hosts not connected to SSL, it claims that a file to upload is not available.

I have several errors in a host because I ran out of the disk space so my fault. These units use a lot of space. Corrected
ID: 6731 · Report as offensive    Reply Quote
CIA

Send message
Joined: 5 Apr 20
Posts: 13
Credit: 84,696
RAC: 253
Message 6732 - Posted: 23 Apr 2020, 22:18:44 UTC
Last modified: 23 Apr 2020, 22:18:54 UTC

I think I might have had one come over SSL but it failed: https://ralph.bakerlab.org/result.php?resultid=4987908

Beyond that I've switched most of my other machines to the SSL and I'm not getting anything fresh, but I also suspect there's no work to send so that's probably why I'm not getting anything.

Are the units that were sent out useful or were they just to test the SSL connection? I still have a bunch in progress on machines I haven't switched to SSL. If it was just a SSL test I'll abort them and swap my remaining machines to https.
ID: 6732 · Report as offensive    Reply Quote
Profile dekim
Volunteer moderator
Project administrator
Project developer
Project scientist

Send message
Joined: 20 Jan 06
Posts: 250
Credit: 542,654
RAC: 0
Message 6733 - Posted: 24 Apr 2020, 0:22:38 UTC

I queued up more jobs. I'm not sure what is happening with the very short run failures.
ID: 6733 · Report as offensive    Reply Quote
CIA

Send message
Joined: 5 Apr 20
Posts: 13
Credit: 84,696
RAC: 253
Message 6734 - Posted: 24 Apr 2020, 0:35:46 UTC - in response to Message 6733.  

I queued up more jobs. I'm not sure what is happening with the very short run failures.


Of the new ones you just sent, I got a bunch on SSL on my Macs, but oddly none on my windows PC's...
ID: 6734 · Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 9 Apr 08
Posts: 676
Credit: 1,314,864
RAC: 2,955
Message 6735 - Posted: 24 Apr 2020, 5:43:00 UTC - in response to Message 6734.  

Of the new ones you just sent, I got a bunch on SSL on my Macs, but oddly none on my windows PC's...

I switch my principal pc to https (it's win10) but queue is empty.
Please, more work to test this new configuration.
ID: 6735 · Report as offensive    Reply Quote
William Albert

Send message
Joined: 31 Mar 20
Posts: 1
Credit: 17,487
RAC: 2
Message 6737 - Posted: 24 Apr 2020, 8:07:05 UTC
Last modified: 24 Apr 2020, 8:07:24 UTC

I switched over my personal fleet, as well as the machines attached to the EZ Texting Infrastructure account.

I did a few spot checks, and so far, everything look good! (Although it looks like I abandoned a bunch of WU's as a result. Oops...)
ID: 6737 · Report as offensive    Reply Quote
Trotador

Send message
Joined: 7 May 10
Posts: 33
Credit: 14,403,306
RAC: 333
Message 6738 - Posted: 25 Apr 2020, 7:22:32 UTC - in response to Message 6733.  

I queued up more jobs. I'm not sure what is happening with the very short run failures.


Still happening in the last batch

https://ralph.bakerlab.org/workunit.php?wuid=4484345
ID: 6738 · Report as offensive    Reply Quote
yoerik

Send message
Joined: 28 Mar 20
Posts: 9
Credit: 2,536
RAC: 1
Message 6743 - Posted: 28 Apr 2020, 2:05:31 UTC - in response to Message 6723.  

no clue what happened - but it won't let me remove the http:// - the remove button is just shaded out.
ID: 6743 · Report as offensive    Reply Quote
Trotador

Send message
Joined: 7 May 10
Posts: 33
Credit: 14,403,306
RAC: 333
Message 6744 - Posted: 28 Apr 2020, 11:23:29 UTC

All units seem to be failing across all hosts
ID: 6744 · Report as offensive    Reply Quote
Trotador

Send message
Joined: 7 May 10
Posts: 33
Credit: 14,403,306
RAC: 333
Message 6745 - Posted: 28 Apr 2020, 12:19:58 UTC - in response to Message 6744.  

All units seem to be failing across all hosts


Well, many of them, not all
ID: 6745 · Report as offensive    Reply Quote
yoerik

Send message
Joined: 28 Mar 20
Posts: 9
Credit: 2,536
RAC: 1
Message 6760 - Posted: 30 Apr 2020, 7:30:01 UTC - in response to Message 6743.  

I was stupid lol. Resolved using account manager ;/
ID: 6760 · Report as offensive    Reply Quote

Message boards : News : Testing a switch to using SSL (Secure Socket Layer)



©2020 University of Washington
http://www.bakerlab.org