Posts by mirabilos

1) Message boards : RALPH@home bug list : alt_platform not honoured (Message 3994)
Posted 5 May 2008 by mirabilos
Post:
This is *EXACTLY* what alt_platform is for.

MirBSD can execute applications for MirBSD, OpenBSD 3.8, and Linux.
The alt_platform says it can run i686-pc-linux-gnu applications, but
is ignored by RALPH.

If I run a hacked BOINC which reports i686-pc-linux-gnu INSTEAD of
i386-ecce-mirbsd as platform, I get WUs, process them, return them,
and they validate. So there is ABSOLUTELY NO reason to not send out
WUs to MirBSD clients.
2) Message boards : RALPH@home bug list : alt_platform not honoured (Message 3930)
Posted 20 Apr 2008 by mirabilos
Post:
Some minirosetta-1.13 results on MirBSD succeed (if I
patch the BOINC binary to identify itself as Linux).
Thus I urge you to fix that on the server.

One of the validated examples:

http://ralph.bakerlab.org/result.php?resultid=922456
3) Message boards : RALPH@home bug list : Bug Reports for Rosetta Mini Versions 1.+ (Message 3872)
Posted 10 Apr 2008 by mirabilos
Post:
Had 20 work units fail with same error

<core_client_version>5.10.45</core_client_version>
<![CDATA[
<message>
process exited with code 1 (0x1, -255)
</message>
<stderr_txt>
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of minirosetta_database_rev20940.zip or
        minirosetta_database_rev20940.zip.zip, and cannot find minirosetta_database_rev20940.zip.ZIP, period.

ERROR: Unable to open file: minirosetta_database/chemical/residue_type_sets/fa_standard/residue_types.txt

ERROR:: Exit from: src/core/chemical/ResidueTypeSet.cc line: 85
called boinc_finish



Make that another 20 that have failed


Add another two:
one on Debian GNU/Linux testing (i386),
the other one on MirBSD #10-current (i386) after temporarily
connecting with a hacked boinc executable to fool the server
into giving me a task, see http://ralph.bakerlab.org/forum_thread.php?id=376.

The ZIP archive extracts just fine in both cases by the way.
4) Message boards : RALPH@home bug list : alt_platform not honoured (Message 3860)
Posted 9 Apr 2008 by mirabilos
Post:
I have BOINC running and reporting back to, for
example, the Sudoku Project. Now, the scheduler
request for this project contains:

<scheduler_request>
  …
    <platform_name>i386-ecce-mirbsd</platform_name>
    <alt_platform>
        <name>i686-pc-linux-gnu</name>
    </alt_platform>
  …
</scheduler_request>


But the server responds with:
platform 'i386-ecce-mirbsd' not found


SZTAKI Desktop Grid, ABC@home and Riesel Sieve
have the same problems; I reported it there too.
Please fix your server.






©2021 University of Washington
http://www.bakerlab.org