Posts by CIA

1) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6829)
Posted 28 May 2020 by CIA
Post:
I only got one recent Ralph WU but it didn't fare so well on my OSX machine, or on another Linux machine that also tried.

https://ralph.bakerlab.org/workunit.php?wuid=4615810
2) Message boards : News : Rosetta version 4.20 released for testing (Message 6798)
Posted 1 May 2020 by CIA
Post:
Just want to give a shoutout to the mods/admins/programmers involved with both Rosetta and Ralph. After following the issue that was brought up over on Rosetta about file sizes and watching the quick response from the dev team to research the proposed solution, and then act on it so quickly. Great job overall!

Well done chaps!
3) Message boards : News : Rosetta version 4.18 released for testing (Message 6770)
Posted 30 Apr 2020 by CIA
Post:
The improvements in this update include:

1. The use of a lock file so only one job extracts the database into the project directory while other jobs wait, including graphics. Once the database is extracted, all jobs read the same database.

2. Checkpointing added to the Rosetta comparative modeling method.

Please test these updates and let us know if there are any issues. Thanks!


Normal "Show Graphics" and screen saver graphics appear to be working under OS X with the 4.18 app.

More info: There is a 10-15 second delay in starting the screensaver, the screen goes black and seems to not work, but this just may be a Boinc thing. I don't run the screensaver so can't comment if this is normal. The screen saver does eventually kick in and act normally.
4) Message boards : News : New application version 4.17 graphics has issues. (Message 6763)
Posted 30 Apr 2020 by CIA
Post:

/edit-update. I don't know if it's a BOINC or Rosetta bug, but the 4.16 "Show Graphics" option pops up the graphics in a small window, and if you resize that window at all it goes black and stops showing the graphics.


Same on Windows but after awaiting ~min black screen fills with correct image and graphics work again.


You are correct, I just never had the patience to wait it out. 8-)
5) Message boards : News : New application version 4.17 graphics has issues. (Message 6757)
Posted 29 Apr 2020 by CIA
Post:
There were some fixes for Mac OS X (64-bit Intel) screen savers released in BOINC version 7.16.6 on 3 April 2020. If you are in the Mac OS X (64-bit Intel) and are not at the current recommended level you might want to upgrade to current.

Bill F


I'm on OSX, Boinc version 7.16.6 and the 4.17 app screensaver/"Show Graphics" option both do not work. The 4.16 version will show graphics and screensaver.

/edit-update. I don't know if it's a BOINC or Rosetta bug, but the 4.16 "Show Graphics" option pops up the graphics in a small window, and if you resize that window at all it goes black and stops showing the graphics.
6) Message boards : News : New application version 4.17 graphics has issues. (Message 6753)
Posted 28 Apr 2020 by CIA
Post:
I've never actually had the graphics turned on for any of my OSX machines. Tried it with 4.17 and it starts to load the screensaver, but then fails apparently and kicks back to the desktop.
7) Message boards : News : Testing a switch to using SSL (Secure Socket Layer) (Message 6734)
Posted 24 Apr 2020 by CIA
Post:
I queued up more jobs. I'm not sure what is happening with the very short run failures.


Of the new ones you just sent, I got a bunch on SSL on my Macs, but oddly none on my windows PC's...
8) Message boards : News : Testing a switch to using SSL (Secure Socket Layer) (Message 6732)
Posted 23 Apr 2020 by CIA
Post:
I think I might have had one come over SSL but it failed: https://ralph.bakerlab.org/result.php?resultid=4987908

Beyond that I've switched most of my other machines to the SSL and I'm not getting anything fresh, but I also suspect there's no work to send so that's probably why I'm not getting anything.

Are the units that were sent out useful or were they just to test the SSL connection? I still have a bunch in progress on machines I haven't switched to SSL. If it was just a SSL test I'll abort them and swap my remaining machines to https.
9) Message boards : News : Testing a switch to using SSL (Secure Socket Layer) (Message 6725)
Posted 23 Apr 2020 by CIA
Post:
We are testing a switch to using https:// (SSL). Please post any issues in the discussion of this news post.


I switched a few machines over, but am not getting work on them. At the same time I'm getting loads of work on my older non-SSL Ralph boxes.
10) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6700)
Posted 6 Apr 2020 by CIA
Post:
https://boinc.bakerlab.org/rosetta/result.php?resultid=1141395048

Another failure on a different machine, but same message. "finish file present too long"

Are these just bugs in the work units? The same machine had 8 cores, 8 tasks going all at once, starting at the same time. They all finished at almost the same time... Of the 8, two failed, and 6 finished without error.


/edit. Sorry this is from Rosetta 4.15, not Ralph, but figured here would be the place to ask.
11) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6699)
Posted 6 Apr 2020 by CIA
Post:
Not sure if the failed WU's are because of the batch, because of the application, or because of the machine, but both my MacPro's (2012, Xeon based) are showing mixed results on 4.15 over on Rosetta. (Not Ralph.)
Host: https://boinc.bakerlab.org/rosetta/show_host_detail.php?hostid=3876438
Example "error while computing" after apparently completing tasks ~8hrs:
https://boinc.bakerlab.org/rosetta/result.php?resultid=1141134856
https://boinc.bakerlab.org/rosetta/result.php?resultid=1141134857

And several more... But also at the same time several other WU's did complete without issue:
https://boinc.bakerlab.org/rosetta/result.php?resultid=1141134616
https://boinc.bakerlab.org/rosetta/result.php?resultid=1141134621

Other host is showing similar returns...
https://boinc.bakerlab.org/rosetta/show_host_detail.php?hostid=3752305

Still waiting on my other older machines to compete units. So far just the MacPro's are showing oddities.
12) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6688)
Posted 6 Apr 2020 by CIA
Post:
I went ahead and posted the OSX update on R@h. We plan to update the rest of the platforms in the next day or so.


I only have my laptop here at home, 2012 MacBook Pro, latest Catalina, 2.93GHz Ivy Bridge i7 but it seems to be running normal Rosetta 4.15 tasks fine so far, whereas it would fail instantly running all 4.12 tasks.
13) Message boards : RALPH@home bug list : Rosetta 4.12+ (Message 6685)
Posted 6 Apr 2020 by CIA
Post:
Signed up after the call out over on the normal Rosetta forums. Been having issues with 4.12 on my older OSX machines (everything pre-2015 it seems fails all tasks immediately as many have reported).

I'm not sure if it's lack of WU or if something changed but my newer OSX machines (that always worked on 4.12) are happily crunching 4.14 units, but I'm not getting any units for the older machines that were having 4.12 issues. Are there no test WU's or are they now being cut out on purpose on the machines that they were failing on?


Rosetta 4.09 and Rosetta Mini continue to work on all machines. (All OSX machines running Bonic 7.14.4)


/edit I should add I'm not getting any 4.14 or later tasks on Ralph@home test machines older then 2015. More recent machines are getting tasks 4.14 and crunching fine.

All my machines did not like 4.13.

/edit 2 The bulk of my machines are in my office, won't be able to force them to try and grab more work until about 12 hours from now when I'm back at work.






©2020 University of Washington
http://www.bakerlab.org