Bug reports for Ralph 5.24

Message boards : RALPH@home bug list : Bug reports for Ralph 5.24

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Rhiju
Volunteer moderator
Project developer
Project scientist

Send message
Joined: 14 Feb 06
Posts: 161
Credit: 3,725
RAC: 0
Message 1842 - Posted: 19 Jun 2006, 3:28:38 UTC

We\'ve added a couple features:

(1) We can now use prior predictions for which parts of the chain are buried or exposed to guide the Rosetta search.

(2) We can efficiently assemble predefined domains of the protein chain into a whole structure.

If this round of ralph goes well, we\'ll probably update the application on Rosetta@home later this week!
ID: 1842 · Report as offensive    Reply Quote
doc :)

Send message
Joined: 16 Feb 06
Posts: 46
Credit: 4,437
RAC: 0
Message 1845 - Posted: 19 Jun 2006, 14:11:01 UTC

id love to run 5.24, but i am getting \"no work from project\".
i thought there was supposed to be work available at any time now? :)
server status page is all green, it only shows no WUs ready to send.
ID: 1845 · Report as offensive    Reply Quote
Profile feet1st

Send message
Joined: 7 Mar 06
Posts: 313
Credit: 113,747
RAC: 0
Message 1846 - Posted: 19 Jun 2006, 18:49:42 UTC

Still no work.
ID: 1846 · Report as offensive    Reply Quote
bt1228

Send message
Joined: 22 Mar 06
Posts: 7
Credit: 9,385
RAC: 0
Message 1847 - Posted: 19 Jun 2006, 23:39:14 UTC

I just received this error:

2006-Jun-19 7:34:43 pm|ralph@home|Requesting 366120 seconds of new work
2006-Jun-19 7:34:48 pm|ralph@home|Scheduler request succeeded
2006-Jun-19 7:34:48 pm|ralph@home|Message from server: No work sent
2006-Jun-19 7:34:48 pm|ralph@home|Message from server: (reached daily quota of 1 results)

Is there actually a quota of one (1) result per day ?

I do have one 5.24 WU in my current task list.

--- bt
ID: 1847 · Report as offensive    Reply Quote
doc :)

Send message
Joined: 16 Feb 06
Posts: 46
Credit: 4,437
RAC: 0
Message 1848 - Posted: 20 Jun 2006, 1:03:44 UTC

no clue how your quota got that low, i got mine by 18 right now, after a couple of errors.
finally got some 5.24 work, all of them that got their turn so far errored out with incorrect function.
all had names like t299_LOOPRELAX_hom00X_S_000XX_000XXXX_0_727_1_X and i was not the only one where those failed.
the result page contains the following error:

<stderr_txt>
ERROR:: Unable to obtain sequence information.
fasta file must be provided.
ERROR:: Exit at: .\\initialize.cc line:236

</stderr_txt>
ID: 1848 · Report as offensive    Reply Quote
Profile Carlos_Pfitzner
Avatar

Send message
Joined: 16 Feb 06
Posts: 182
Credit: 22,792
RAC: 0
Message 1849 - Posted: 20 Jun 2006, 3:25:54 UTC

9 jobs with this error on Windows and 2 jobs on Linux

process exited with code 1 (0x1)
</message>
<stderr_txt>
Graphics are disabled due to configuration...
ERROR:: Unable to obtain sequence information.
fasta file must be provided.
ERROR:: Exit at: initialize.cc line:236

I am somewhat lazy by now to provide a link for each WU -;

So, a link to 1 on Linux
http://ralph.bakerlab.org/result.php?resultid=187655
and a link to 1 on Windows
http://ralph.bakerlab.org/result.php?resultid=187566

Thanks


Click signature for global team stats
ID: 1849 · Report as offensive    Reply Quote
Deborah Goldsmith

Send message
Joined: 16 Feb 06
Posts: 3
Credit: 233,275
RAC: 36
Message 1850 - Posted: 20 Jun 2006, 6:07:02 UTC

Mac OS X (Intel), failed immediately on running the application:
2006-06-19 16:59:46 [ralph@home] Starting task t299_LOOPRELAX_hom004_S_00018_0004609_0_728_2_0 using rosetta_beta version 524
2006-06-19 16:59:48 [ralph@home] Unrecoverable error for result t299_LOOPRELAX_hom004_S_00018_0004609_0_728_2_0 (process exited with
code 1 (0x1))
2006-06-19 16:59:48 [ralph@home] Unrecoverable error for result t299_LOOPRELAX_hom004_S_00018_0004609_0_728_2_0 (process exited with
code 1 (0x1))
2006-06-19 16:59:48 [---] Rescheduling CPU: application exited

It did this 12 times in a row before exhausting the daily quota.

5.24 is working fine on my PPC machines. 5.23 worked fine on my Intel machine. This failure appears to be Intel-specific and 5.24-specific.

ID: 1850 · Report as offensive    Reply Quote
[B^S] suguruhirahara

Send message
Joined: 5 Mar 06
Posts: 40
Credit: 6,001
RAC: 0
Message 1851 - Posted: 20 Jun 2006, 10:13:55 UTC

http://ralph.bakerlab.org/result.php?resultid=187639
<stderr_txt>
ERROR:: Unable to obtain sequence information.
fasta file must be provided.
ERROR:: Exit at: .\\initialize.cc line:236

</stderr_txt>

ID: 1851 · Report as offensive    Reply Quote
Profile feet1st

Send message
Joined: 7 Mar 06
Posts: 313
Credit: 113,747
RAC: 0
Message 1852 - Posted: 20 Jun 2006, 14:16:09 UTC

6 failed in a row upon startup. Same Fasta file not found error.
ID: 1852 · Report as offensive    Reply Quote
doc :)

Send message
Joined: 16 Feb 06
Posts: 46
Credit: 4,437
RAC: 0
Message 1853 - Posted: 20 Jun 2006, 15:05:23 UTC

just a little update, after those failures i had with my first couple of 5.24s i have some successes now (they are out of another WU batch as far as i can tell though, 731 instead of 727 in my case, so it was probably just a bad batch of WUs)
ID: 1853 · Report as offensive    Reply Quote
Rhiju
Volunteer moderator
Project developer
Project scientist

Send message
Joined: 14 Feb 06
Posts: 161
Credit: 3,725
RAC: 0
Message 1854 - Posted: 20 Jun 2006, 21:36:48 UTC - in response to Message 1853.  

Thanks for posting. I think it was just all the simultaneous downloading produced some strain on our fileserver and some users got incomplete jobs. Once things settled down, we don\'t seem to be seeing many errors!

just a little update, after those failures i had with my first couple of 5.24s i have some successes now (they are out of another WU batch as far as i can tell though, 731 instead of 727 in my case, so it was probably just a bad batch of WUs)


ID: 1854 · Report as offensive    Reply Quote
Rhiju
Volunteer moderator
Project developer
Project scientist

Send message
Joined: 14 Feb 06
Posts: 161
Credit: 3,725
RAC: 0
Message 1855 - Posted: 20 Jun 2006, 21:41:12 UTC - in response to Message 1845.  

We tried the \"continuous work for ralph\" for a week or so, but our turnaround time for testing new WUs was just too slow! It would take about 24 hours for computers to free up, accept new WUs, and give back initial results -- we want the tunaround time to be less than 12 hours. Hope that\'s a reasonable explanation!

My advice is to crunch for both rosetta@home and ralph, if you haven\'t already... the good news is that we\'re setting up the debugging stuff over on rosetta@home, so we\'ll be hopefully be getting a steady stream of callstacks from whatever errors are going on over there too!

id love to run 5.24, but i am getting \"no work from project\".
i thought there was supposed to be work available at any time now? :)
server status page is all green, it only shows no WUs ready to send.


ID: 1855 · Report as offensive    Reply Quote
Profile feet1st

Send message
Joined: 7 Mar 06
Posts: 313
Credit: 113,747
RAC: 0
Message 1856 - Posted: 20 Jun 2006, 22:14:22 UTC - in response to Message 1855.  

...we want the tunaround time to be less than 12 hours.


This doesn\'t leave you much time to test running the WUs for 24hrs then. Nor much time to test running in environments where you aren\'t the only application.

ID: 1856 · Report as offensive    Reply Quote
Profile feet1st

Send message
Joined: 7 Mar 06
Posts: 313
Credit: 113,747
RAC: 0
Message 1857 - Posted: 20 Jun 2006, 22:30:46 UTC

Looking back in my messages, I see that I did complete a download of a fasta file prior to the 6 WUs that failed on startup.

6/19/2006 6:45:30 PM|ralph@home|Started download of file nterm_nohelix3_hom001_t299_.fasta.gz
6/19/2006 6:45:31 PM|ralph@home|Finished download of file nterm_nohelix3_hom001_t299_.fasta.gz

I see no failed attempts to download any other fasta files when those WUs came down. It seems there may be more to the story then a busy server.
ID: 1857 · Report as offensive    Reply Quote
Rhiju
Volunteer moderator
Project developer
Project scientist

Send message
Joined: 14 Feb 06
Posts: 161
Credit: 3,725
RAC: 0
Message 1858 - Posted: 20 Jun 2006, 23:18:33 UTC - in response to Message 1857.  

Hmm, thanks for checking on this. I\'ll look at those WUs more carefully...

Looking back in my messages, I see that I did complete a download of a fasta file prior to the 6 WUs that failed on startup.

6/19/2006 6:45:30 PM|ralph@home|Started download of file nterm_nohelix3_hom001_t299_.fasta.gz
6/19/2006 6:45:31 PM|ralph@home|Finished download of file nterm_nohelix3_hom001_t299_.fasta.gz

I see no failed attempts to download any other fasta files when those WUs came down. It seems there may be more to the story then a busy server.


ID: 1858 · Report as offensive    Reply Quote
Rhiju
Volunteer moderator
Project developer
Project scientist

Send message
Joined: 14 Feb 06
Posts: 161
Credit: 3,725
RAC: 0
Message 1859 - Posted: 20 Jun 2006, 23:26:34 UTC - in response to Message 1858.  
Last modified: 20 Jun 2006, 23:27:15 UTC

OK, I checked those jobs. Looks like those work units all failed for the same known reason (a problem in the submitter\'s submission script), and then were fixed and sent out again. The second round went well. Phew. It wasn\'t the app!

By the way, its pretty great that we had so many postings -- its very useful to get this continuous feedback .

Hmm, thanks for checking on this. I\'ll look at those WUs more carefully...

Looking back in my messages, I see that I did complete a download of a fasta file prior to the 6 WUs that failed on startup.

6/19/2006 6:45:30 PM|ralph@home|Started download of file nterm_nohelix3_hom001_t299_.fasta.gz
6/19/2006 6:45:31 PM|ralph@home|Finished download of file nterm_nohelix3_hom001_t299_.fasta.gz

I see no failed attempts to download any other fasta files when those WUs came down. It seems there may be more to the story then a busy server.



ID: 1859 · Report as offensive    Reply Quote
Profile Carlos_Pfitzner
Avatar

Send message
Joined: 16 Feb 06
Posts: 182
Credit: 22,792
RAC: 0
Message 1860 - Posted: 21 Jun 2006, 3:04:58 UTC - in response to Message 1855.  
Last modified: 21 Jun 2006, 3:06:36 UTC

We tried the \"continuous work for ralph\" for a week or so, but our turnaround time for testing new WUs was just too slow! It would take about 24 hours for computers to free up, accept new WUs, and give back initial results -- we want the tunaround time to be less than 12 hours. Hope that\'s a reasonable explanation!

My advice is to crunch for both rosetta@home and ralph, if you haven\'t already... the good news is that we\'re setting up the debugging stuff over on rosetta@home, so we\'ll be hopefully be getting a steady stream of callstacks from whatever errors are going on over there too!

id love to run 5.24, but i am getting \"no work from project\".
i thought there was supposed to be work available at any time now? :)
server status page is all green, it only shows no WUs ready to send.



I make a new host, venue school , connect to network every second , running *only* ralph@home

*This one should download only 1 job at a time, crunch and upload, report
and then download the next -:) and on and on

However my WUs are failing on them !

May be a host setup problem ?
-or- just bad WUs ?

Exit status -1073741684 (0xffffffffc000008c)
http://ralph.bakerlab.org/result.php?resultid=190094
http://ralph.bakerlab.org/result.php?resultid=190240
http://ralph.bakerlab.org/result.php?resultid=190262

any help appreciated -> this host owns a virtual CPU
and had crunched simap and einstein , with no problems -:)

my host specs
Average upload rate 0.53 KB/sec
Average download rate 9.59 KB/sec
Average turnaround time 0 days

Also was able to meet TANPAKU deadline of 1 hour

Thanks
Click signature for global team stats
ID: 1860 · Report as offensive    Reply Quote
Profile Carlos_Pfitzner
Avatar

Send message
Joined: 16 Feb 06
Posts: 182
Credit: 22,792
RAC: 0
Message 1861 - Posted: 21 Jun 2006, 14:38:27 UTC - in response to Message 1860.  

We tried the \"continuous work for ralph\" for a week or so, but our turnaround time for testing new WUs was just too slow! It would take about 24 hours for computers to free up, accept new WUs, and give back initial results -- we want the tunaround time to be less than 12 hours. Hope that\'s a reasonable explanation!

My advice is to crunch for both rosetta@home and ralph, if you haven\'t already... the good news is that we\'re setting up the debugging stuff over on rosetta@home, so we\'ll be hopefully be getting a steady stream of callstacks from whatever errors are going on over there too!

id love to run 5.24, but i am getting \"no work from project\".
i thought there was supposed to be work available at any time now? :)
server status page is all green, it only shows no WUs ready to send.



I make a new host, venue school , connect to network every second , running *only* ralph@home

*This one should download only 1 job at a time, crunch and upload, report
and then download the next -:) and on and on

However my WUs are failing on them !

May be a host setup problem ?
-or- just bad WUs ?

Exit status -1073741684 (0xffffffffc000008c)
http://ralph.bakerlab.org/result.php?resultid=190094
http://ralph.bakerlab.org/result.php?resultid=190240
http://ralph.bakerlab.org/result.php?resultid=190262

any help appreciated -> this host owns a virtual CPU
and had crunched simap and einstein , with no problems -:)

my host specs
Average upload rate 0.53 KB/sec
Average download rate 9.59 KB/sec
Average turnaround time 0 days

Also was able to meet TANPAKU deadline of 1 hour

Thanks


Found the problem, and fixed it. was a corrupted NTFS virtual FileSystem

Now the problem is another

Outcome Client error
Client state Downloading
Exit status -186 (0xffffffffffffff46


I looked at the download progress,
and before all files of the WU has finished downloading,
the job started to run, and imediatelly got this error.
http://ralph.bakerlab.org/result.php?resultid=190486

I am believing on a ralph server problem, or my ISP had some glitch with my Link
Anyway the job (WU) should not start to run before all files downloaded

Now,
I\'ll wait there is work again ... Xlab (backup project)
is downloading / crunching / uploading 100% OK ;)

I select Xlab to \"backup project\" cause their WUs crunch in 9 minutes
so, when there is work, immediattely the vpc switch to ralph.

Thanks
Click signature for global team stats
ID: 1861 · Report as offensive    Reply Quote
[B^S] sTrey
Avatar

Send message
Joined: 15 Feb 06
Posts: 58
Credit: 15,430
RAC: 0
Message 1862 - Posted: 22 Jun 2006, 3:05:43 UTC
Last modified: 22 Jun 2006, 3:07:22 UTC

Errored out on t299__CASP7_ABRELAX_SAVE_ALL_OUT_TEST_ASSEMBLE_hom001__753_34_0 with -161
<file_xfer_error>
<file_name>t299__CASP7_ABRELAX_SAVE_ALL_OUT_TEST_ASSEMBLE_hom001__753_34_0_0
</file_name>
<error_code>-161</error_code>
ID: 1862 · Report as offensive    Reply Quote
Profile anders n

Send message
Joined: 16 Feb 06
Posts: 166
Credit: 131,419
RAC: 0
Message 1863 - Posted: 22 Jun 2006, 13:52:16 UTC
Last modified: 22 Jun 2006, 13:52:32 UTC

Error -WARNING! attempt to gzip file .\\xxt299.out failed: file does not exist.
on this wu http://ralph.bakerlab.org/result.php?resultid=191298

Anders n
ID: 1863 · Report as offensive    Reply Quote
1 · 2 · Next

Message boards : RALPH@home bug list : Bug reports for Ralph 5.24



©2018 University of Washington
http://www.bakerlab.org