RALPH@home

Bug reports for 5.84

  UW Seal
 
[ Home ] [ Join ] [ About ] [ Participants ] [ Community ] [ Statistics ]
  [ login/out ]


Advanced search

Message boards : RALPH@home bug list : Bug reports for 5.84

AuthorMessage
Rhiju
Forum moderator
Project developer
Project scientist

Joined: Feb 14 06
Posts: 161
ID: 4
Credit: 3,725
RAC: 0
Message 3467 - Posted 16 Nov 2007 4:44:33 UTC

    Thanks for posting!
    ____________

    Pepo
    Avatar

    Joined: Sep 8 06
    Posts: 104
    ID: 1812
    Credit: 36,890
    RAC: 0
    Message 3468 - Posted 16 Nov 2007 9:57:09 UTC

      2o1j__BOINC_SYMM_FOLD_AND_DOCK_RELAX-2o1j_-crystal_foldanddock__2561_10_0 failed after 1.6 second with exit code -529697949 (0xffffffffe06d7363): \"Unhandled Exception: Out Of Memory (C++ Exception) (0xe06d7363) at address 0x7C812A5B\", with Boinc debug dump. On WinXP, Boinc 5.10.30.
      Another 1irq__BOINC_SYMM_FOLD_AND_DOCK_RELAX-1irq_-crystal_foldanddock__2561_10_0 one hour later successfully generated one decoy.

      Peter

      (What about switching the akispamet off?)

      BigMike
      Avatar

      Joined: Feb 23 06
      Posts: 63
      ID: 738
      Credit: 58,730
      RAC: 0
      Message 3470 - Posted 21 Nov 2007 8:11:50 UTC

        Last modified: 21 Nov 2007 8:30:19 UTC

        Several of my recent WU\'s failed with this error:

        <core_client_version>5.10.28</core_client_version>
        <![CDATA[
        <message>
        Incorrect function. (0x1) - exit code 1 (0x1)
        </message>
        <stderr_txt>
        # cpu_run_time_pref: 7200
        # random seed: 1823551
        ERROR:: Exit from: .\\fragments.cc line: 726

        </stderr_txt>
        ]]>

        669497 669403 669362 669204

        ==Mike

        PS. The spam filter is getting obnoxious. We can\'t use standard URL\'s any more. It needs to be shut off.
        ____________
        Don't believe everything you think.

        Pieface

        Joined: Feb 16 06
        Posts: 64
        ID: 234
        Credit: 203,513
        RAC: 0
        Message 3475 - Posted 21 Nov 2007 15:21:55 UTC

          Last modified: 21 Nov 2007 15:25:24 UTC

          Hmmm where did that last post go? spam filter is driving me nutso-bonzo.
          I had three die same as bigmike, 669839, 669973 and 669490. Also this one resultid=668956 that went down at hbonds.cc line: 641

          Papagiorgio

          Joined: Nov 2 06
          Posts: 3
          ID: 2159
          Credit: 26,100
          RAC: 0
          Message 3476 - Posted 21 Nov 2007 21:28:19 UTC

            I use beta version 5.85 but I believe, this thread is the right one, because I got the same error result as BigMike:

            <core_client_version>5.10.28</core_client_version>
            <![CDATA[
            <message>
            Unzulässige Funktion. (0x1) - exit code 1 (0x1)
            </message>
            <stderr_txt>
            # cpu_run_time_pref: 28800
            # random seed: 1823536
            ERROR:: Exit from: .\\fragments.cc line: 726

            </stderr_txt>
            ]]>

            It is resultid=669215
            Don´t know, how to post the link....

            Matthias

            Dr Who Fan
            Avatar

            Joined: Sep 2 06
            Posts: 63
            ID: 1787
            Credit: 46,809
            RAC: 0
            Message 3484 - Posted 27 Nov 2007 2:10:23 UTC

              Last modified: 27 Nov 2007 2:14:08 UTC

              Version 5.85 bug...

              http://ralph.bakerlab.org/result.php?resultid=671905

              CPU time 22.546875
              stderr out

              <core_client_version>5.10.28</core_client_version>
              <![CDATA[
              <message>
              Incorrect function. (0x1) - exit code 1 (0x1)
              </message>
              <stderr_txt>

              </stderr_txt>
              ]]>

              ____________

              Dr Who Fan
              Avatar

              Joined: Sep 2 06
              Posts: 63
              ID: 1787
              Credit: 46,809
              RAC: 0
              Message 3485 - Posted 27 Nov 2007 2:11:26 UTC

                Last modified: 27 Nov 2007 2:11:43 UTC

                dupe

                BigMike
                Avatar

                Joined: Feb 23 06
                Posts: 63
                ID: 738
                Credit: 58,730
                RAC: 0
                Message 3487 - Posted 1 Dec 2007 15:13:58 UTC

                  Something strange seems to be happening with WU 602302. So far, everyone who has crunched it has gotten a Validate Error when it is returned.

                  I thought it was just me, but it also happened to the next person to crunch it, and my money is on the third person getting it too.

                  ==Mike
                  ____________
                  Don't believe everything you think.

                  Profile Trog Dog
                  Avatar

                  Joined: Aug 8 06
                  Posts: 38
                  ID: 1670
                  Credit: 41,996
                  RAC: 0
                  Message 3488 - Posted 2 Dec 2007 2:05:52 UTC

                    A spate of errors here - all variations of the folllowing


                    <core_client_version>5.10.30</core_client_version>
                    <![CDATA[
                    <message>
                    process exited with code 255 (0xff, -1)
                    </message>
                    <stderr_txt>
                    Graphics are disabled due to configuration...
                    # cpu_run_time_pref: 3600
                    Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 6
                    ERROR:: Exit from: fragments_ns.cc line: 245

                    </stderr_txt>
                    ]]>




                    ____________

                    BigMike
                    Avatar

                    Joined: Feb 23 06
                    Posts: 63
                    ID: 738
                    Credit: 58,730
                    RAC: 0
                    Message 3492 - Posted 2 Dec 2007 8:09:55 UTC - in response to Message 3487.

                      So far, everyone who has crunched it has gotten a Validate Error when it is returned ... my money is on the third person getting it too.


                      I guess the third time really is the charm. The third crunch was successful. Glad I didn\'t go to Vegas.

                      ==Mike
                      ____________
                      Don't believe everything you think.

                      ramostol

                      Joined: Mar 29 07
                      Posts: 24
                      ID: 2840
                      Credit: 31,121
                      RAC: 0
                      Message 3493 - Posted 2 Dec 2007 12:15:01 UTC

                        Last modified: 2 Dec 2007 12:15:51 UTC

                        A non-fatal issue, and a general one I expect, but this time concerning a 5.85 task.

                        The watchdog report to Bakerlab shows no problems at all:

                        http://ralph.bakerlab.org/result.php?resultid=679198:

                        1bgf__BOINC_ABINITIO_VFSCORE25-13-_SKIP3-1bgf_-vf__2629_2_0

                        stderr out
                        <core_client_version>5.10.30</core_client_version>
                        <![CDATA[
                        <stderr_txt>
                        Rosetta@home Macintosh Stack Size checker.
                        Original size: 0.
                        Maximum size: 8388608.
                        RLIM_INFINITY 0
                        # cpu_run_time_pref: 14400
                        # random seed: 1808482
                        Rosetta@home Macintosh Stack Size checker.
                        Original size: 0.
                        Maximum size: 8388608.
                        RLIM_INFINITY 0
                        # cpu_run_time_pref: 14400
                        ======================================================
                        DONE :: 1 starting structures 13106.9 cpu seconds
                        This process generated 7 decoys from 7 attempts
                        ======================================================


                        BOINC :: Watchdog shutting down...
                        BOINC :: BOINC support services shutting down...

                        </stderr_txt>
                        ]]>

                        From local message file:

                        30-Nov-2007 21:53:43 [ralph@home] Computation for task 1bk2__BOINC_ABINITIO_VFSCORE25-7-_SKIP3-1bk2_-vf__2623_3_0 finished
                        30-Nov-2007 21:53:43 [ralph@home] Starting 1bgf__BOINC_ABINITIO_VFSCORE25-13-_SKIP3-1bgf_-vf__2629_2_0
                        30-Nov-2007 21:53:44 [ralph@home] Starting task 1bgf__BOINC_ABINITIO_VFSCORE25-13-_SKIP3-1bgf_-vf__2629_2_0 using rosetta_beta version 585
                        01-Dec-2007 00:55:27 [ralph@home] Restarting task 1bgf__BOINC_ABINITIO_VFSCORE25-13-_SKIP3-1bgf_-vf__2629_2_0 using rosetta_beta version 585

                        The message file confirms that this wu has been restarted. No explanation is given, and the computer was running unattended with no disturbing network connections at the time, so I have no more leads.

                        And I was kind of expecting the watchdog to report 7 decoys from 8 attempts after this restart.

                        Profile Conan
                        Avatar

                        Joined: Feb 16 06
                        Posts: 344
                        ID: 145
                        Credit: 1,310,876
                        RAC: 100
                        Message 3494 - Posted 3 Dec 2007 14:04:27 UTC

                          Last modified: 3 Dec 2007 14:08:16 UTC

                          3rd time lucky posting this.

                          Heaps of Errors (29 of them) all Linux, all the same error:-

                          <core_client_version>5.10.21</core_client_version>
                          <![CDATA[
                          <message>
                          process exited with code 255 (0xff, -1)
                          </message>
                          <stderr_txt>
                          Graphics are disabled due to configuration...
                          # cpu_run_time_pref: 21600
                          Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                          ERROR:: Exit from: fragments_ns.cc line: 245

                          Examples WU 681002 and WU 681447

                          Also had 3 errors on Windows:--

                          WU 669765 has exit code 1 .....\\fragments.cc line. 726

                          Plus WU 660933 and WU 651172 have unhandled exception error


                          This spam filter of yours is getting to be a real pain in the backside. Each time I post here to report an error, I get deleted as Spam.

                          We are volunteers trying to help you, but if it keeps taking 2 and 3 times to get a post to stay without being deleted then people are going to stop posting in the errors results that you want to make your WU\'s better.

                          We will keep crunching them but a lot will stop posting the errors as it will be too much of a bother and take too much time (this one has taken me over 1/2 hour to finally get posted.

                          ____________

                          Profile Conan
                          Avatar

                          Joined: Feb 16 06
                          Posts: 344
                          ID: 145
                          Credit: 1,310,876
                          RAC: 100
                          Message 3495 - Posted 4 Dec 2007 4:22:20 UTC - in response to Message 3494.

                            3rd time lucky posting this.

                            Heaps of Errors (29 of them) all Linux, all the same error:-

                            <core_client_version>5.10.21</core_client_version>
                            <![CDATA[
                            <message>
                            process exited with code 255 (0xff, -1)
                            </message>
                            <stderr_txt>
                            Graphics are disabled due to configuration...
                            # cpu_run_time_pref: 21600
                            Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                            ERROR:: Exit from: fragments_ns.cc line: 245

                            Examples WU 681002 and WU 681447

                            Also had 3 errors on Windows:--

                            WU 669765 has exit code 1 .....\\fragments.cc line. 726

                            Plus WU 660933 and WU 651172 have unhandled exception error


                            This spam filter of yours is getting to be a real pain in the backside. Each time I post here to report an error, I get deleted as Spam.

                            We are volunteers trying to help you, but if it keeps taking 2 and 3 times to get a post to stay without being deleted then people are going to stop posting in the errors results that you want to make your WU\'s better.

                            We will keep crunching them but a lot will stop posting the errors as it will be too much of a bother and take too much time (this one has taken me over 1/2 hour to finally get posted.


                            Another 4 errors
                            This WU
                            This WU
                            This WU
                            This WU

                            All had the same error

                            process exited with code 255 (0xff, -1)
                            </message>
                            <stderr_txt>
                            Graphics are disabled due to configuration...
                            # cpu_run_time_pref: 21600
                            Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                            ERROR:: Exit from: fragments_ns.cc line: 245
                            ____________

                            Profile Conan
                            Avatar

                            Joined: Feb 16 06
                            Posts: 344
                            ID: 145
                            Credit: 1,310,876
                            RAC: 100
                            Message 3496 - Posted 4 Dec 2007 10:01:50 UTC - in response to Message 3495.

                              3rd time lucky posting this.

                              Heaps of Errors (29 of them) all Linux, all the same error:-

                              <core_client_version>5.10.21</core_client_version>
                              <![CDATA[
                              <message>
                              process exited with code 255 (0xff, -1)
                              </message>
                              <stderr_txt>
                              Graphics are disabled due to configuration...
                              # cpu_run_time_pref: 21600
                              Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                              ERROR:: Exit from: fragments_ns.cc line: 245

                              Examples WU 681002 and WU 681447

                              Also had 3 errors on Windows:--

                              WU 669765 has exit code 1 .....\\fragments.cc line. 726

                              Plus WU 660933 and WU 651172 have unhandled exception error


                              This spam filter of yours is getting to be a real pain in the backside. Each time I post here to report an error, I get deleted as Spam.

                              We are volunteers trying to help you, but if it keeps taking 2 and 3 times to get a post to stay without being deleted then people are going to stop posting in the errors results that you want to make your WU\'s better.

                              We will keep crunching them but a lot will stop posting the errors as it will be too much of a bother and take too much time (this one has taken me over 1/2 hour to finally get posted.


                              Another 4 errors
                              This WU
                              This WU
                              This WU
                              This WU

                              All had the same error

                              process exited with code 255 (0xff, -1)
                              </message>
                              <stderr_txt>
                              Graphics are disabled due to configuration...
                              # cpu_run_time_pref: 21600
                              Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                              ERROR:: Exit from: fragments_ns.cc line: 245


                              I have had another 18 WU\'s fail of the VFSCORE3 type.

                              This takes the total to about 50 that have failed with the same error after only a few seconds of run time.
                              ____________

                              BigMike
                              Avatar

                              Joined: Feb 23 06
                              Posts: 63
                              ID: 738
                              Credit: 58,730
                              RAC: 0
                              Message 3497 - Posted 5 Dec 2007 2:10:10 UTC

                                Caught an error that was reported as valid (Result 684302)

                                <core_client_version>5.10.28</core_client_version>
                                <![CDATA[
                                <stderr_txt>
                                # cpu_run_time_pref: 7200
                                # random seed: 1791862
                                sin_cos_range ERROR: 1.0511052 is outside of [-1,+1] sin and cos value legal range
                                ======================================================
                                DONE :: 1 starting structures 6993.56 cpu seconds
                                This process generated 24 decoys from 24 attempts
                                ======================================================


                                BOINC :: Watchdog shutting down...
                                BOINC :: BOINC support services shutting down...

                                </stderr_txt>
                                ]]>


                                ____________
                                Don't believe everything you think.

                                BigMike
                                Avatar

                                Joined: Feb 23 06
                                Posts: 63
                                ID: 738
                                Credit: 58,730
                                RAC: 0
                                Message 3498 - Posted 5 Dec 2007 2:44:55 UTC

                                  Not a good day. All four of the new cfr WU\'s that I got crashed:

                                  <core_client_version>5.10.28</core_client_version>
                                  <![CDATA[
                                  <message>
                                  Incorrect function. (0x1) - exit code 1 (0x1)
                                  </message>
                                  <stderr_txt>
                                  # cpu_run_time_pref: 7200
                                  ERROR:: Unable to determine sequence length from pdb file
                                  ERROR:: Exit from: .\\pose.cc line: 1929

                                  </stderr_txt>
                                  ]]>

                                  686058 686059 686072 686073

                                  ____________
                                  Don't believe everything you think.

                                  Saxbryn

                                  Joined: Oct 15 07
                                  Posts: 1
                                  ID: 3638
                                  Credit: 272
                                  RAC: 0
                                  Message 3500 - Posted 5 Dec 2007 16:29:46 UTC

                                    Last modified: 5 Dec 2007 16:33:19 UTC

                                    Not sure wether this is a bug worth reporting and if this is the right thread for it, but since it is the first workunit that failed on me (and two other crunchers), I thought I better mention it (I know, bit late, just noticed today):

                                    605457

                                    (Using 5.85 beta)

                                    Profile Conan
                                    Avatar

                                    Joined: Feb 16 06
                                    Posts: 344
                                    ID: 145
                                    Credit: 1,310,876
                                    RAC: 100
                                    Message 3502 - Posted 6 Dec 2007 4:41:51 UTC

                                      Have had another 7 WU\'s fail with the same error that my last 50 that failed had

                                      Changing the WU name from VFSCORE3 to VF_SCORE3 has made no difference.

                                      All had the same error

                                      process exited with code 255 (0xff, -1)
                                      </message>
                                      <stderr_txt>
                                      Graphics are disabled due to configuration...
                                      # cpu_run_time_pref: 21600
                                      Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16
                                      ERROR:: Exit from: fragments_ns.cc line: 245
                                      ____________

                                      BigMike
                                      Avatar

                                      Joined: Feb 23 06
                                      Posts: 63
                                      ID: 738
                                      Credit: 58,730
                                      RAC: 0
                                      Message 3503 - Posted 6 Dec 2007 5:32:52 UTC

                                        Just had 12 WU\'s fail almost immediately the same way as this one

                                        <core_client_version>5.10.28</core_client_version>
                                        <![CDATA[
                                        <message>
                                        Incorrect function. (0x1) - exit code 1 (0x1)
                                        </message>
                                        <stderr_txt>
                                        # cpu_run_time_pref: 3600
                                        ERROR:: Exit from: .\\fragments.cc line: 465

                                        </stderr_txt>
                                        ]]>

                                        ==Mike

                                        ____________
                                        Don't believe everything you think.

                                        Pepo
                                        Avatar

                                        Joined: Sep 8 06
                                        Posts: 104
                                        ID: 1812
                                        Credit: 36,890
                                        RAC: 0
                                        Message 3504 - Posted 6 Dec 2007 13:08:30 UTC

                                          Last modified: 6 Dec 2007 13:13:41 UTC

                                          5 x the same error as BigMike mentioned (\"Incorrect function. (0x1) - exit code 1 (0x1), ERROR:: Exit from: .\\fragments.cc line: 465\"): results 689005, 688961, 688506, 688423, 689759, named \"1****_BOINC_ABINITIO_BEST25_VF_SCORE3-1*--1****-vf__2657_*_*\".
                                          All wingmen immediately failed too.

                                          Peter

                                          Rhiju
                                          Forum moderator
                                          Project developer
                                          Project scientist

                                          Joined: Feb 14 06
                                          Posts: 161
                                          ID: 4
                                          Credit: 3,725
                                          RAC: 0
                                          Message 3506 - Posted 6 Dec 2007 18:07:37 UTC - in response to Message 3504.

                                            We\'re looking into it -- I just contacted Rob, who can probably give you an update on these tests.

                                            5 x the same error as BigMike mentioned (\"Incorrect function. (0x1) - exit code 1 (0x1), ERROR:: Exit from: .\\fragments.cc line: 465\"): results 689005, 688961, 688506, 688423, 689759, named \"1****_BOINC_ABINITIO_BEST25_VF_SCORE3-1*--1****-vf__2657_*_*\".
                                            All wingmen immediately failed too.

                                            Peter


                                            ____________

                                            robert

                                            Joined: Dec 6 07
                                            Posts: 3
                                            ID: 3851
                                            Credit: 0
                                            RAC: 0
                                            Message 3507 - Posted 6 Dec 2007 22:45:47 UTC

                                              The VF runs are testing variable fragment sizes, ranging from 3 to 25 mers instead of the 3 and 9 mers traditional rosetta abinitio uses.

                                              The \"Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16\" error is what the old version of rosetta used to say whenever it encountered a fragment sized outside of the norm. This was fixed for 5.85, but unfortunately when the ralph versions were updated these changes were not properly applied to the linux specific executable.

                                              That has now been fixed, so we certainly don\'t expect to see that error again.

                                              On the other hand the more recent BEST25_VFSCORE3 errors were entirely my fault. Evidently even when rosetta doesn\'t need 3mers for abinitio it still checks to see if they exist, and fails if they don\'t. Some of these runs don\'t use 3mers at all, so I thought I could save people some space by leaving them out of the jobs. Now, this is a mistake we would normally catch on our local machines. Unfortunately I ended up doing my tests with 3mers present anyway and didn\'t catch the problem before sending it to ralph. I managed to remove the jobs once the first error messages started coming back, but by that point at least a thousand were already in progress.

                                              I definitely apologize for wasting your computational time on this, and to anyone affected, thank you for helping to catch my mistakes before they went to boinc.

                                              BigMike
                                              Avatar

                                              Joined: Feb 23 06
                                              Posts: 63
                                              ID: 738
                                              Credit: 58,730
                                              RAC: 0
                                              Message 3508 - Posted 6 Dec 2007 23:35:41 UTC - in response to Message 3507.

                                                I definitely apologize for wasting your computational time on this...

                                                Not a problem as far as I am concerned.

                                                And thank you for explaining what\'s happening. It makes a difference to know someone is actually reading these posts. And I enjoy hearing about the nuts and bolts of Rosetta :)

                                                ==Mike

                                                ____________
                                                Don't believe everything you think.

                                                BigMike
                                                Avatar

                                                Joined: Feb 23 06
                                                Posts: 63
                                                ID: 738
                                                Credit: 58,730
                                                RAC: 0
                                                Message 3509 - Posted 6 Dec 2007 23:40:56 UTC

                                                  Last modified: 6 Dec 2007 23:42:45 UTC

                                                  It seems version 5.85 now has its very own message thread

                                                  See you over there...

                                                  ==Mike
                                                  ____________
                                                  Don't believe everything you think.

                                                  Profile Conan
                                                  Avatar

                                                  Joined: Feb 16 06
                                                  Posts: 344
                                                  ID: 145
                                                  Credit: 1,310,876
                                                  RAC: 100
                                                  Message 3511 - Posted 7 Dec 2007 21:36:30 UTC - in response to Message 3507.

                                                    The VF runs are testing variable fragment sizes, ranging from 3 to 25 mers instead of the 3 and 9 mers traditional rosetta abinitio uses.

                                                    The \"Incorrect fragment size requested for omega alignment. Expected 1,3, or 9, but actually got: 16\" error is what the old version of rosetta used to say whenever it encountered a fragment sized outside of the norm. This was fixed for 5.85, but unfortunately when the ralph versions were updated these changes were not properly applied to the linux specific executable.

                                                    That has now been fixed, so we certainly don\'t expect to see that error again.

                                                    On the other hand the more recent BEST25_VFSCORE3 errors were entirely my fault. Evidently even when rosetta doesn\'t need 3mers for abinitio it still checks to see if they exist, and fails if they don\'t. Some of these runs don\'t use 3mers at all, so I thought I could save people some space by leaving them out of the jobs. Now, this is a mistake we would normally catch on our local machines. Unfortunately I ended up doing my tests with 3mers present anyway and didn\'t catch the problem before sending it to ralph. I managed to remove the jobs once the first error messages started coming back, but by that point at least a thousand were already in progress.

                                                    I definitely apologize for wasting your computational time on this, and to anyone affected, thank you for helping to catch my mistakes before they went to boinc.


                                                    Thanks for the update. Not a real problem I suppose as this is an Alpha project but I was wondering why it took 3 days to respond. I started reporting these problems back on the 3rd.
                                                    No worries, the only harm done is that I wont be able to do any more Ralph jobs for awhile due to all the dozens of errors (I had well over 50 of them), Boinc will not request any more work, and when it does it will only ask for a few jobs till I get successful ones returned.
                                                    ____________

                                                    Message boards : RALPH@home bug list : Bug reports for 5.84


                                                    Home | Join | About | Participants | Community | Statistics

                                                    Copyright © 2017 University of Washington

                                                    Last Modified: 20 Nov 2008 19:41:56 UTC
                                                    Back to top ^